
 
 
  

CSI Solution Demonstrates Use of These Features 
� Grid lines 

� Divide frames 

� Frame releases 

� Steel Design 



Problem A Solution 
1. Click the File menu > New Model command to access the New Model form. 

2. Click the drop-down box to set the units to . 

3. Click the 2D Frames button  to display the 2D Frames form. In that form: 

� Select Portal in the 2D Frame Type drop-down list. 

� Type 5 in the Number of Stories edit box. 

� Type 4 in the Number of Bays edit box. 

� Type 13 in the Story Height edit box. 

� Type 25 in the Bay Width edit box. 

� Click the OK button. 

4. Click the “X” in the top right-hand corner of the 3-D View window to close that view. 

5. Click the Set Display Options toolbar button  (or click the View menu > Set Display 

Options command) to display the Display Options for Active Window form. In that 
form: 

� Check the Labels box in the Joints area. 

� Check the Labels box in the Frames/Cables area. 

� Click the OK button. 

6. Select column objects 18, 19, 20, 23, 24 and 25 and beam objects 38, 39, 40, 43, 44 
and 45.  Press the delete key on the keyboard to delete those objects. 

Note:   Objects can be selected by clicking on each one individually, “windowing” over 
them, using the Intersecting Line Select Mode, or using the Select menu > Select > 

Labels command. 

7. Click the Define menu > Coordinate Systems/Grids command to display the 
Coordinate/Grid Systems form. 

8. Click on GLOBAL in the Systems list box to highlight it (select it), and then click the 
Modify/Show System button to display the Define Grid Data for {Name} Coordinate 

System form. In that form: 

� Check the Glue to Grid Lines box in the right middle of the form. 

� In the X Grid Data area, click in the Ordinate cell for Grid ID x5 (it should read 
50 now). Type 53 in the edit box.  

� In the Z Grid Data area, click in the Ordinate cell for Grid ID z1 (it should read 0 
now). Type -1 in the edit box. 

� Click the OK button on the Define Grid Data for {Name} Coordinate System 
form and the Coordinate/Grid Systems form. 

9. Click the Refresh Window button  to refresh the drawing. 



10. Select beams 41 and 42. 

11. Click the Edit menu > Divide Frames command to display the Divide Selected Frames 
form. 

12.  Fill in the form as shown in the figure 
(typically the form will default to these 
values) and click the OK button. 

13. Click the drop-down box in the status bar to 

change the units to . 

14. Click the Define menu > Materials 
command to display the Define Materials 
form. 

15. Click on STEEL in the Materials area to 
highlight it (select it), and then click the Modify/Show Material button to display the 
Material Property Data form. In that form: 

� Type 0 in the Mass per Unit Volume edit box. 

� Type 0 in the Weight per Unit Volume edit box. 

� Type 29500 in the Modulus of Elasticity edit box. 

� Type .3 in the Poisson’s Ratio edit box, if it is not already entered. 

� Type 0 in the Coeff of Thermal Expansion edit box. 

� Type 36 in the Minimum Yield Stress, Fy edit box, if it is not already entered. 

� Type 58 in the Minimum Tensile Stress, Fu edit box. 

� Click the OK button. 

16. Click on CONC in the Materials area to highlight it (select it), and then click the 
Modify/Show Material button to display the Material Property Data form. In that form: 

� Type 4000 in the Modulus of Elasticity edit box. 

� Type .22 in the Poisson’s Ratio edit box 

� Click the OK button to accept these values and the other values on the form. 

17. Click the OK button to close the Define Materials form. 

18. Click the drop-down box in the status bar to change the units to . 

19. Click the Define menu > Materials command to display the Define Materials form. 

20. Click on CONC in the Materials area to highlight it (select it), and then click the 
Modify/Show Material button to display the Material Property Data form. In that form: 

� Verify 0.15 is displayed in the Weight per Unit Volume edit box. 

� Click the OK buttons on the Material Property Data form and the Define 
Materials form. 

21. Click the Define menu > Frame Sections command to display the Frame Properties 
form. 

22. In the Choose Property Type to Add area, click the drop-down box that reads Import 
I/Wide Flange, highlight the Import I/Wide Flange item, and then click on the Add New 
Property button. 



23. If the Section Property File form appears, locate the Sections.pro file, which should be 
located in the same directory as the SAP2000 program files. Highlight Sections.pro 
and click the Open button. 

24. A form appears with a list of all wide flange sections in the database. In that form: 

� Scroll down and click on the W16X36 section. 

� Click the OK button on the form and on the next form to return to the Frame 
Properties form. 

25. In the Choose Property Type to Add area, click the drop-down box that reads Import 
I/Wide Flange, highlight the Import Box/Tube item, and then click on the Add New 
Property button. 

26. A form appears with a list of all structural tube sections in the database. In that form: 

� Scroll up/down and click on the TS6X6X1/4 section. 

� Click the OK button on the database form, the Box/Tube Section form, and the 
Frame Properties form to exit all of forms. 

27. Click the Define menu > Area Sections command to display the Area Sections form. 

28. In the Click To area, click the Add New Section button to display the Area Section Data 
form. In that form: 

� Type WALL in the Section Name edit box. 

� In the Thickness area type .6667 in both the Membrane and the Bending edit 
boxes. 

� Verify that the Shell option is selected in the Type area. 

� Click the OK button. 

29. Click the OK button to close the Area Sections form. 

30. Verify that the Snap to Points and Grid Intersections button  is depressed. 

31. Click the Draw Frame/Cable/Tendon Element button  or select the Draw menu > 

Draw Frame/Cable/Tendon command to display the Properties of Object form. In that 
form: 

� Click in the Property cell to display a drop-down list. Scroll up/down and click on 
the TS6X6X1/4 section to assign it to the line objects that you will draw. 

� In the Moment Releases drop-down list, click on Pinned. 

32. Draw the first brace object as follows: 

� Place the mouse pointer on joint 19. When the text box reading “Point” appears, 
click the left mouse button once. 

� Move the mouse pointer to joint 31. When the text box reading “Point” appears, 
click the left mouse button once. 

� Press the Enter key on the keyboard. 

33. Click on joint 25 and then joint 31, and press the Enter key to draw the second brace 
element. 

34. Click on joint 20 and then joint 32, and press the Enter key to draw the third brace 
element. 



35. Click on joint 26 and then joint 32, and press the Enter key to draw the fourth and final 
brace element. 

36. Click the Set Select Mode button  to exit Draw mode and enter Select mode. 

37. Select all of the beams except for the braced frame beams (i.e., select beams 26 
through 37 and do not select beams 46 through 49). The Intersecting Line Selection 
option could be useful for this. 

Note:  To use the Intersecting Line Selection option, click the Select Using Intersecting 

Line button . Then click the left mouse button at the top of one beam bay, and 
while holding down the left mouse button, drag the mouse to the bottom of the beam 
bay. A “rubberband line” will appear and all objects that this “rubberband line” passes 
through will be selected.  Release the left mouse button to make the selection. 

38. Click the Assign menu > Frame/Cable/Tendon > Releases/Partial Fixity command to 
display the Assign Frame Releases form. In that form, check both the Start and the 
End boxes for Moment 33 (Major) and then click the OK button. 

39. Select beam objects 46 and 48. 

40. Click the Assign menu > Frame/Cable/Tendon > Releases/Partial Fixity command to 
display the Assign Frame Releases form. In that form, check the Start box for Moment 
33 (Major) and then click the OK button. 

41. Select beam objects 47 and 49. 

42. Click the Assign menu > Frame/Cable/Tendon > Releases/Partial Fixity command to 
display the Assign Frame Releases form. In that form, check the End box for Moment 
33 (Major) and then click the OK button. 

43. Click the Define menu > Load Cases command to display the Define Loads form. In 
that form: 

� Type LL in the Load Name edit box. 

� Select Live from the Type drop-down box. 

� Type 0 in the Self Weight Multiplier edit box. 

� Click the Add New Load button. 

� Type EQ in the Load Name edit box. 

� Select Quake from the Type drop-down box. 

� Click the Add New Load button. 

� Click the OK button. 

44. Click the Define menu > Combinations command to display the Define Response 
Combinations form. In that form: 

� Click the Add New Combo button to display the Response Combination Data 
form. In that form: 

o Type ALL in the Response Combination Name edit box. 

o Select Linear Add from the Combination Type drop-down box if it is not 
already selected. 

o If not already set, select the DEAD load case in the Case Name drop-
down box and type 1 in the Scale Factor edit box. 



o Click the Add button. 

o Select the LL load case in the Case Name drop-down box. 

o Click the Add button. 

o Select the EQ load case in the Case Name drop-down box. 

o Click the Add button. 

o Click the OK button on the Response Combination Data form and the 
Define Response Combinations form. 

45. Select beams 26 through 37. 

46. Click the Assign menu > Frame/Cable/Tendon Loads > Point command to display the 
Frame Point Loads form. In that form: 

� Select DEAD from the Load Case Name drop-down box. 

� In the Load Type and Direction area, make sure that Forces is selected and 
that Gravity (-Z) shows in the Direction drop-down box. 

� In the Point Loads area type .5 in the first Distance edit box and type 10 in the 
first Load edit box. 

� Click the OK button. 

47. Click the Get Previous Selection button  (or the Select menu > Get Previous 

Selection command). 

48. Click the Assign menu > Frame/Cable/Tendon Loads > Distributed command to 
display the Frame Distributed Loads form. In that form: 

� Select DEAD from the Load Case Name drop-down box. 

� In the Load Type and Direction area, make sure that Forces is selected and 
that Gravity (-Z) shows in the Direction drop-down box. 

� Type 1.2 in the Uniform Load area Load edit box. 

� Click the OK button. 

49. Click the Get Previous Selection button  (or the Select menu > Get Previous 

Selection command). 

50. Click the Assign menu > Frame/Cable/Tendon Loads > Point command to display the 
Frame Point Loads form. In that form: 

� Select LL from the Load Case Name drop-down box. 

� In the Point Loads area type 5 in the first Load edit box 

� Click the OK button. 

51. Click the Get Previous Selection button  (or click the Select menu > Get Previous 

Selection command). 

52. Click the Assign menu > Frame/Cable/Tendon Loads > Distributed command to 
display the Frame Distributed Loads form. In that form: 

� Select LL from the Load Case Name drop-down box. 



� In the Load Type and Direction area, make sure that Forces is selected and 
that Gravity (-Z) shows in the Direction drop-down box. 

� Type .8 in the Uniform Load area Load edit box. 

� Click the OK button. 

53. Select beams 46 through 49. 

54. Click the Assign menu > Frame/Cable/Tendon Loads > Distributed command to 
display the Frame Distributed Loads form. In that form: 

� Select DEAD from the Load Case Name drop-down box. 

� Type 1.2 in the Uniform Load area Load edit box. 

� Click the OK button. 

55. Click the Get Previous Selection button   (or click the Select menu > Get Previous 

Selection command). 

56. Click the Assign menu > Frame/Cable/Tendon Loads > Distributed command to 
display the Frame Distributed Loads form. In that form: 

� Select LL from the Load Case Name drop-down box. 

� Type .8 in the Uniform Load area Load edit box. 

� Click the OK button. 

57. Select joints 31 and 32. 

58. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Select DEAD from the Load Case Name drop-down box. 

� Type -10 in the Force Global Z edit box in the Loads area. 

� Click the OK button. 

59. Click the Get Previous Selection button   (or the Select menu > Get Previous 

Selection command). 

60. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Select LL from the Load Case Name drop-down box. 

� Type -5 in the Force Global Z edit box in the Loads area. 

� Click the OK button. 

61. Select joints 2, 3, 4, 5 and 6 by “windowing.” 

62. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Select EQ from the Load Case Name drop-down box. 

� Type 10 in the Force Global X edit box in the Loads area. 

� Type 0 in the Force Global Z edit box in the Loads area. 

� Click the OK button. 



63. Select joints 3, 4, 5 and 6 (not 2) by “windowing.” 

64. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Verify Add to Existing Loads is selected in the Options area. 

� Click the OK button. 

65. Select joints 4, 5 and 6 (not 2 and 3) by “windowing.” 

66. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Verify Add to Existing Loads is selected in the Options area. 

� Click the OK button. 

67. Select joints 5 and 6 (not 2, 3 and 4). 

68. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Verify Add to Existing Loads is selected in the Options area. 

� Click the OK button. 

69. Select joint 6 (not 2, 3, 4 and 5). 

70. Click the Assign menu > Joint Loads > Forces command to display the Joint Forces 
form. In that form: 

� Verify Add to Existing Loads is selected in the Options area. 

� Click the OK button. 

71. Select beams 26 through 37. 

72. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Scroll down and click on W24X68 in the Properties area to highlight it. 

� Click the OK button. 

73. Click the Show Undeformed Shape button  to remove the displayed frame section 
assignments and display the frame object labels again. 

74. Select beams 46 through 49. 

75. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Scroll down and click on W16X36 in the Properties area to highlight it. 

� Click the OK button. 

76. Select all of the columns. An easy way to do this is to “window” each of the column 
lines separately. 

Note:  To “window” a column line, left click the mouse above and to the left of the 
column line.  While holding the left mouse button down, drag the mouse so that it is 
below and to the right of the column line.  A “rubberband window” will appear 
surrounding the column line.  Release the left mouse button to select all objects that 
are fully enclosed by the “rubberband window.” 



77. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Scroll down and click on W10X49 in the Properties area to highlight it. 

� Click the OK button. 

78. Click the Show Undeformed Shape button  to remove the displayed frame section 
assignments. 

79. Click the Set Display Options button  (or select the View menu > Set Display 

Options command) to display the Display Options for Active Window form. In that 
form: 

� Uncheck the Labels box in the Joints area. 

� Uncheck the Labels box in the Frames/Cables/Tendon area. 

� Click the OK button. 

80. Click the Quick Draw Area Element button  to display the Properties of Object 
form. In that form: 

� Scroll down and select WALL from the Property drop-down box. 

81. Click the mouse pointer once in the areas labeled A, B, C, D and E in the figure below 
to draw the area objects. 

 

82. Click the Set Select Mode button to exit Draw mode and enter Select mode. 

83. Select the five area objects just entered by clicking on them. 

84. Click the Assign menu > Area > Automatic Area Mesh command to display the Assign 
Automatic Area Mesh form. 

85. Fill out that form as shown in the figure to mesh each area object into twelve elements 
(4 by 3) and click the OK button. 



86. Click the Set Display Options button  (or select the View menu > Set Display 

Options menu) to display the Display Options for Active Window form. In that form: 

� Check the Not in View box in the Joints area. 

� Check the Sections box in the Frames/Cables/Tendon area. 

� Check the Not in View box in the Areas area. 

� Click the OK button. 

87. Select all of the W24X68 beam sections (12 total). 

88. Click the Design menu > Steel Frame Design > View/Revise Overwrites command to 
display the Steel Frame Design Overwrites form. In that form: 

� Select the Unbraced Length Ratio (Minor, LTB) box and type .3333 in the 
associated edit box. 

� Click the OK button. 

89. Click the Clear Selection button  (or click the Select menu > Clear Selection 
command). 

90. Select all of the W16X36 beam sections (4 total). 

91. Click the Design menu > Steel Frame Design > View/Revise Overwrites command to 
display the Steel Frame Design Overwrites form. In that form: 

� Select the Unbraced Length Ratio (Minor, LTB) box and type .5 in the 
associated edit box. 

� Click the OK button. 

92. Click the Set Display Options button  (or select the View menu > Set Display 

Options command) to display the Display Options for Active Window form. In that 
form: 

� Uncheck the Not in View box in the Joints area. 

� Check the Restraints box in the Joints area. 

� Uncheck the Sections box in the Frames/Cables/Tendon area. 

� Uncheck the Not in View box in the Areas area. 

� Click the OK button. 

93. Click the Options menu > Preferences > Steel Frame Design command to display the 
Steel Frame Design Preferences form. In that form: 

� Select AISC-ASD89 from the Design Code drop-down box if it is not already 
selected. 

� Click the OK button. 

94. Click the Analyze menu > Set Analysis Options command to display the Analysis 
Options form. In that form, click the Plane Frame XZ Plane button to set the available 
degrees of freedom and click the OK button. 

95. Click the Run Analysis button  to display the Set Analysis Cases to Run form. In 
that form: 



� Click on Modal in the Case Name list to highlight it. 

� Click the Run/Do Not Run Case button. 

� Click the Run Now button. 

96. When the analysis is complete, check the messages in the Analysis window (there 
should be no warnings or errors) and then click the OK button to close the Analysis 
window. 

97. Click the Display menu > Show Forces/Stresses > Joints command to display the 
Joint Reaction Forces form. In that form: 

� Select ALL from the Case/Combo Name drop-down box. 

� Verify that the Reactions option is selected in the Type area. 

� Click the OK button. 

98. The reactions are displayed on the screen. If the text is too small to read, zoom in, or 
change the minimum font size as described in the following Note. 

Note:   To change the minimum font size, click the Options menu > Preferences > 

Dimensions/Tolerances command.  In the Minimum Graphic Font Size edit box input a 
new size, for example 5 or 6 points. Click the OK button.   

99. Click the Design menu > Steel Frame Design > Start Design/Check of Structure 
command to run the design check of the steel frame objects. 

100. When the design check completes, a color map of the stress ratios is displayed. 


