Problem C

Truss Frame

Steel Frame

E =29000 ksi, Poissons Ratio=03

All steel members are L4xd angles, Fy =36ksi
Base is pinned

Diaphragms
Concrete diaphragms are 8" thick with a unit weight of 150 pcf

hodel as rigid diaphragm at Levels Aand B
Additional dead load at each diaphragm is 50 psf
Live load at each diaphragm is 100 psf

To Do
Size steel members for DL + LL using AISC - ASDE3
Determine the first three modes of vibration
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Typical Elevation
(All four sides are the same)

CSI Solution Demonstrates Use of These Features
= Diaphragm Constraint

= Design Optimization

= Automatic Area Mesh

= Mode Shapes

= New Model (not from template, started from scratch)

= Linear Replication



= Mirror Replication
= Radial Replication

= Steel Design

Problem C Solution

1. Click the File menu > New Model command to displays the New Model form.

2. Click the drop-down box to set the units to M

Blank

3. Click the Blank button

4. Click the Define menu > Coordinate Systems/Grids command to display the
Coordinate/Grid Systems form.

5. In that form click on the Modify/Show System button to display the Define Grid Data
form. Fill in the form as shown in Figure C-1. Type values in the Grid ID and Ordinate
cells; click in the Line Type, Visibility, and Bubble Loc. cells until the appropriate option
appears:
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Figure C-1 Defining the Grid System

= Click the OK buttons on the Coordinate/Grid System Data and Coordinate/Grid
Systems forms to exit the forms.

6. Click in the left window entitled 3-D View to make sure it is active. The window is
highlighted when it is active.

3-d
7. Click the set Default 3D View button . to change to the default 3-d view.

8. Click in the right window entitled 3-D View to make sure it is active. Click the Set Xz

view button = to change the view to an X-Z elevation. Note that the title of the
window changes to X-Z Plane @ Y=0.



9. Click the Quick Draw Frame/Cable/Tendon button or click the braw menu >
Quick Draw Frame/Cable/Tendon command to display the Properties of Object form.
By default, the Line Object Type should be Straight Frame. If it is not, click in that box
to display the drop-down list and click on Straight Frame to select it. We will ignore the
other property settings shown because other assignments will be made later in the
modeling process.

10. Click on the grid line at the point labeled “A” in Figure C-2 to enter a frame object.

11. Click on the grid line at the point labeled “B” in Figure C-2 to enter another frame

object.
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Figure C-2 Initial Grid Layout in X-Z Plane

12. Click the Draw Frame/Cable/Tendon Element button or the Draw menu > Draw
Frame/Cable/Tendon command to display the Properties of Object form. Again, be
sure that the Line Object Type is Straight Frame. We will ignore the other property
settings shown in the form because other assignments will be made later in the
modeling process.

13. Click on the points labeled “C,” “D,” and “E” in Figure C-2, in that order, and then press
the Enter key on the keyboard to draw two more frame objects.

14. Click on the point labeled “F” and then double click the point labeled “E” in Figure C-2
to draw the next frame object.

Note: You could have single-clicked the point labeled “E” in Figure C-2 and then
pressed the Enter key on the keyboard to finish drawing the frame object.

15. Click on the point labeled “G” and then double click the point labeled “D” in Figure C-2
to draw the next frame object.

16. Click on the point labeled “D” and then double click the point labeled “F” in Figure C-2
to draw the next frame object.



18. Click the set Display Options button

17. Click the set Select Mode button ﬁ, to exit Draw Mode and enter Select Mode.

(or the View menu > Set Display Options

command) to display the Display Options for Active Window form. In that form:

= Check the Labels box in the Joints area.

= Check the Labels box in the Frames/Cables/Tendon area.

= Check the Fill Objects box.

= Click the OK button. The screen appears as shown in Figure C-3.
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Figure C-3 Screen as It Appears After Step 18

19. Click on line objects 1 and 3 to select them.

20. Click the Edit menu > Divide Frames

command to display the Divide Selected
Frames form. Verify that this form is filled
out as shown in the adjacent figure and
click the oK button.

21. Click the Draw Frame/Cable/Tendon

e .

button or click the Draw menu > Draw
Frame/Cable/Tendon command. Again, we
can ignore the current property settings

Divide Selected Frames

¢ Dwideino. Frames
LastiFirstratio. [

Break af intersections with selected
Frames and Joints.

[ ok |

displayed in the Properties of Object form.

As an alternate method, we could have defined the sections before drawing the frame
objects, and then assigned the sections when drawing using the Properties of Objects

form.




22. Draw frame objects by single clicking then double clicking on the joints identified in the
following table:

Click on This Joint Double Click on This Joint
9 13
8 12
7 11
6 10
13 2
12 9
11 8
10 7

23. Click the set Select Mode button ﬁ, to exit Draw Mode and enter Select Mode.
24. Click in the Window labeled X-Z Plane @ Y=0 to activate it.

25. Click the select All button ol to select all objects.
26. Click the Edit menu > Replicate command to display the Replicate form. In that form:
= Select the Mirror Tab.
= In the Mirror About Plane area select Parallel to Y.
= In the Intersection of Plane with XZ Plane area type 10.5 in the x1 edit box.
= Type 10.5 in the x2 edit box.

= Click the oK button to proceed with the replication.

27. Click the braw Frame/Cable/Tendon Element button . or the braw menu > Draw
Frame/Cable/Tendon command.

28. Click on joint 4 and then double click on joint 17 to draw a frame object.

Note: If the font size for the joint labels is too small, use the following procedure to
increase the font size. Click the Options menu > Preferences >
Dimensions/Tolerances command and type in a new (larger) font size in the Minimum
Graphic Font Size edit box (usually 6 points is sufficient), click the ok button and then

click the Refresh Window button ‘5, .

To read a particular joint label, right click on the joint to bring up a form that displays
the joint label.

29. Click the set Select Mode button ﬁ, to exit Draw Mode and enter Select Mode.



30. Click the select All button

all® ,
to select all objects.

31. Click the Edit menu > Replicate command to display the Replicate form. In that form:

32.
33.

34.

35.

36.
37.

38.

39.
40.

= Select the Radial Tab.

= In the Rotate About Line area select the Parallel to Z option.

= In the Intersection of Line with XY Plane area verify that X is 0 and Y is O.
= In the Increment Data area verify that the Number is 1 and the Angle is 90.

= Click the OK button to proceed with the replication.

53
Click the Get Previous Selection button BE

Click the Edit menu > Replicate command to display the Replicate form. In that form:
= Verify the Linear Tab is selected.
= In the Increments area type 21 in the dy edit box.
= Verify that O is entered in the dx and dz edit boxes.

= Verify that 1 is entered in the Number edit box.

Click the oK button to proceed with the replication.

Click in the window entitled X-Z Plane @ Y=0 to make sure it is active.

. Lo . .
Click the set YZ view button to change the view to a Y-Z elevation. Note that the
title of the window changes to Y-Z Plane @ X=0.

Select all of the elements in the Y-Z plane @ X=0 by “windowing.”
Click the Edit menu > Replicate command to display the Replicate form. In that form:
= Verify the Linear Tab is selected.
= Inthe Increments area type 21 in the dx edit box.
= In the Increments area type 0 in the dy edit box.
= Verify that 0 is entered in the dz edit box.
= Verify that 1 is entered in the Number edit box.

= Click the OK button to proceed with the replication.

"
Click the set XY View button 7 to change the view to an X-Y plan. Note that the title
of the window changes to X-Y Plane @ Z=0.

Select the four joints at this level by “windowing” or clicking on them individually.

Click the Assign menu > Joint > Restraints command to display the Joint Restraints
form. In that form:

= Verify that the Translation 1, Translation 2 and Translation 3 boxes are
checked.

= Verify that the Rotation About 1, Rotation About 2 and Rotation About 3 boxes
are not checked.

= Click the OK button.



41.

42.

43.

44,

45,
46.
47,

48.

49.

50.

51.

52.

53.

Click the Show Undeformed Shape button = to reset the window display from joint
restraints to undeformed geometry. Note that the window title changes.

Click the Move Up in List button il to display the plan view at Z=25.

Click the braw Rectangular Area Element button O on the side toolbar or the Draw
menu > Draw Rectangular Area command to display the Properties of Object form.
Again, we can ignore the current property setting.

Click on joint 33 and then joint 15 to draw an area object over the entire plan.

Click the set Select Mode button ﬁ, to exit Draw Mode and enter Select Mode.
Click on the area object to select it.

Click the Assign menu > Area > Automatic Area Mesh command to display the Assign
Automatic Area Mesh form.

Fill in this form as shown in Figure C-4 and click the OK button.

Assign Automatic Area Mesh

i Mo duto Meshing
{* L Auto Mesh Area Into This Mumber of Elements

Alang E dge fram Point 1 to 2 |I:I
Along Edge fram Point 1 ta 3 ID

7 Auta Mesh &rea Into Elements of This Magimum Size

[v Add restraints along edge if comers have restraints

=itz

| Kip. tt. F -] ok | Cancel

Figure C-4 Assign Automatic Area Mesh 2 x 2

O

Click the Show Undeformed Shape button to reset the window display.

Click the Move Up in List button il to display the elevation view at Z=37.

Click the Draw Rectangular Area Element button O or the Draw menu > Draw
Rectangular Area command to display the Properties of Object form.

Click on joint 34 and then joint 16 to draw an area object over the entire plan.

Click the set Select Mode button ﬁ, to exit Draw Mode and enter Select Mode.



54. Click on the area object to select it.

55. Click the Assign menu > Area > Automatic Area Mesh command to display the Assign
Automatic Area Mesh form.

56. Fill in this form as shown in the adjacent figure and click the OK button.
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Figure C-5 Assign Automatic Area Mesh 3x 3

57. Click the Show Undeformed Shape button = to reset the window display.

58. Click the Set Display Options button (or the View menu > Set Display Options
command) to display the Display Options for Active Window form. In that form:
= Uncheck the Labels box in the Joints area.
= Uncheck the Labels box in the Frames/Cables/Tendon area.
= Click the ok button.

59. Click the Define menu > Load Cases command to display the Define Loads form. In
that form:

= Type LIVE in the Load Name edit box.

= Select LIVE from the Type drop-down box.

= Verify that 0 is in the Self Weight Multiplier edit box.
= Click the Add New Load button.

= Click the oK button.

60. Click the Define menu > Materials command to display the Define Materials form. In
that form:

= Highlight the CONC material and click the Modify/Show Material button to
display the Material Property Data form. In that form:



o Verify that the Mass per Unit Volume is 4.662E-03.
o Verify that the Weight per Unit Volume is 0.15.
o0 Click the OK buttons on the Material Property Data and Define
Materials forms to exit all forms.
61. Click the drop-down box in the status bar to change the units to {Fip. in. F '},

62. Click the Define menu > Materials command to display the Define Materials form. In
that form:

= Highlight the STEEL material and click the Modify/Show Material button to
display the Material Property Data form. In that form:

o Verify that the Modulus of Elasticity is 29000.
o Verify that Poisson’s ratio is 0.3.

o Verify that the steel yield stress is 36.

o}

Click the OK buttons on the Material Property Data and Define
Materials forms to exit the forms.

63. Click the Define menu > Frame Sections command to display the Frame Properties
form. In that form:

= Click the drop-down box that reads Import I/Wide Flange and select the Import
Angle option.

= Click the Add New Property button to display the Section Property File form.
Locate the Sections.pro file, which should be located in the same directory as
the SAP2000 program files. Highlight Sections.pro and click the open button.

= A form appears with a list of all angle sections in the database. In that form:
o Scroll down and highlight the L4x4x1/2 by clicking on it.

0 Hold down the Shift key on the keyboard and click on the L4x4x7/16
angle. All of the L4x4 angles will now be selected (seven total).

o Click the oK buttons on the two forms to return to the Frame Properties
form.

= Click the drop-down box that reads Add I/Wide Flange and select the Add Auto
Select option.

= Click the Add New Property button to display the Auto Selection Sections form.
In that form:

o Highlight all of the angles in the List of Sections list box by clicking on
the top angle, pressing and holding down the shift key on the
keyboard, and clicking on the bottom angle.

o Click the Add button to add the angles to the Auto Selections list box.
o0 Click the oK buttons on the Auto Selection Sections and Frame
Properties forms to exit all forms.
64. Click the drop-down box in the status bar to change the units to M

65. Click the Define menu > Area Sections command to display the Area Sections form. In
that form:



66.

67.
68.

69.
70.

71.
72.

73.

74.
75.
76.

= Click the Modify/Show Section button to display the Area Section Data form. In
that form:

o Verify the Material specified is CONC.
o Verify that the Shell option is selected in the Area Type area.

o Inthe Thickness area, type .6667 in both the Membrane and Bending
edit boxes.

o

Verify that the Shell option is chosen in the Type area.

Click the OK buttons on the Area Section Data and Area Sections forms
to exit all forms.

o

Click in the 3D View window to make sure it is active.

Al

Click the select All button on the side toolbar to select all objects.

Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display
the Frame Properties form. In that form:

= Highlight the AUTOL section.
= Click the OK button.

Al

Click the select All button to select all elements.

Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area
Uniform Loads form. In that form:

= Verify DEAD is selected in the Load Case Name drop-down box.
= In the Uniform Load area, type .05 (50 psf) in the Load edit box.
= In the Uniform Load area, verify that the Direction item is set to Gravity.

= Click the OK button.

Al

Click the select All button on the side toolbar to select all objects.

Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area
Uniform Loads form. In that form:

= Select LIVE in the Load Case Name drop-down box.
= In the Uniform Load area, type .1 (100 psf) in the Load edit box.
= Click the ok button.

Click the show Undeformed Shape button '

loads.

to remove the display of the area

Click in the window labeled X-Y Plane @ Z=37 to activate it.
Select all of the objects in the plan view by “windowing.”

Click the Assign menu > Joint > Constraints command to display the Assign/Define
Constraints form. In that form:

= In the Choose Constraint Type for Add area, click the drop-down box that reads
Body and select Diaphragm.



7.

78.
79.
80.

81.

82.

83.

84.

= Click the Add New Constraint button to display the Diaphragm Constraint form.
In that form:

o0 Type ROOF in the Constraint Name edit box.
o Verify that the Z Axis option is selected in the Constraint Axis area.

o Click the oK buttons on the Diaphragm Constraint and the
Assign/Define Constraints forms to exit all forms.

Click the show Undeformed Shape button = to remove the display of the joint
constraints and reset the window display.

Click the Move Down in List button * to move to the X-Y Plane @ Z=25.
Select all of the objects in the plan view by “windowing.”

Click the Assign menu > Joint > Constraints command to display the Assign/Define
Constraints form. In that form:

= In the Choose Constraint Type for Add area, click the drop-down box that reads
Body and select Diaphragm.

= Click the Add New Constraint button to display the Diaphragm Constraint form.
In that form:

0 Type SECOND in the Constraint Name edit box.
o Verify that the Z Axis option is selected in the Constraint Axis area.

o0 Click the oK buttons on the Diaphragm Constraint and the
Assign/Define Constraints forms to exit all forms.

Click the show Undeformed Shape button =

constraints and reset the window display.

to remove the display of the joint

Click the Define menu > Analysis Cases command to display the Analysis Cases form.
In that form:

= Click on MODAL in the Case Name list to highlight it.

= Click the Modify/Show Case button to display the Analysis Case Data form. In
that form:

o0 In the Number of Modes area, type 3 in the Maximum Number of
Modes edit box.

o Click the oK buttons on the Analysis Case Data and Analysis Cases
forms to exit all forms.

Click the Options menu > Preferences > Steel Frame Design command to display the
Steel Frame Design Preferences form. In that form:

= Select AISC-ASD89 from the Design Code drop-down box.
= Click the ok button.

. k .
Click the Run Analysis button to display the Set Analysis Cases to Run form. In
that form:

= Verify that the DEAD, MODAL and LIVE analysis cases are all set to Run in the
Action list.



85.

86.

87.

88.

89.

90.

91.

93.

94,

95.

96.

= Click the Run Now button to run the analysis.

When the analysis is complete, check the messages in the SAP Analysis Monitor
window (there should be no warnings or errors) and then click the oK button to close
the Analysis window.

Click the Design menu > Steel Frame Design > Start Design/Check of Structure
command to initiate the design. The design proceeds and when it is complete P-M
interaction ratios are displayed.

Click the Design menu > Steel Frame Design > Display Design Info command to
display the Display Steel Design Results form. In that form:

= Select the Design Input option. Verify that Design Sections is displayed in the
drop-down box.

= Click the OK button. The sections chosen by the program are displayed.

Note: Zoom in using the Rubber Band Zoom button 2 to view the chosen sections
better.

Click the show Undeformed Shape button = to remove the display of frame
sections and interaction colors.

If you have zoomed in for a better view of the chosen sections, then click the Restore

®

Full View button 22—,

Click the Design menu > Steel Frame Design > Verify Analysis vs Design Section
command to display the number of members that changed sections between analysis
and design. If this number is greater than 1, the analysis should be re-run with the
sections chosen during design. Click NO to close the form.

. Ik .
Click the Run Analysis button to display the Set Analysis Cases to Run form. In
that form:

= Verify that the DEAD, MODAL and LIVE analysis cases are all set to Run in the
Action list.

= Click the Run Now button to run the analysis with the updated design sections.

When the analysis is complete check the messages in the SAP Analysis Monitor
window (there should be no warnings or errors) and then click the OK button to close
the Analysis window.

Click the Design menu > Steel Frame Design > Start Design/Check of Structure

command to initiate the design. x|

Click the Design menu > Steel :
Frame Design > Verify Analysis vs ! Analysis and design sections match for all steel frames.

Design Section command to display
the number of members that
changed sections between analysis

and design. Steps 91 through 94
should be repeated until the adjacent form appears. Click OK to close the form.

Click the Design menu > Steel Frame Design > Verify All Members Passed command
to display the number of members that do not pass the stress/capacity check. If
members do not pass the stress/capacity check after all analysis and design sections



97.

98.

99.

100.

101.

match, the Auto Select Sections list will need to be altered to include larger sections.
Click the No button to close the form.

Click the show Deformed Shape button 2 (or the Display menu > Show Deformed
Shape command) to display the Deformed Shape form. In that form:

= Verify that MODAL is selected in the Case/Combo Name drop-down box.
= Type 1 in the Mode Number edit box.

= Click the OK button.

Start Animation

Click the start Animation button , located in the status bar at the
bottom of the SAP2000 window, to animate the mode shape.
Click the Right Arrow button = , located in the status bar at the bottom of the screen,

to view the second mode shape.
Click the Right Arrow button again to view the third mode shape.

Click the Stop Animation button  ={eR&nimation | o ateq in the status bar at

the bottom of the SAP2000 window, to stop the mode shape animation.



