
 

CSI Solution Demonstrates Use of These Features 
� Base (Seismic) Isolation 

� Diaphragm Constraint 

�  Ritz Vectors 

� Dynamic Analysis 

� Mode Shapes 

� Link Elements 



� Modal Nonlinear Time History Analysis 

Problem O Solution 
1. Click the File menu > New Model command to display the New Model form. 

2. Click the drop-down box to set the units to .. 

3. Click the 3D Frame button  to display the 3D Frames form. In that form: 

� Select Open Frame Building from the 3D Frame Type drop-down list. 

� Type 2 in the Number of Bays, X edit box. 

� Type 30 in the Bay Width, X edit box. 

� Type 30 in the Bay Width, Y edit box. 

� Uncheck the Restraints check box. 

�  Accept the rest of the default values. 

� Click the OK button. 

4. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. The window is 
active when its title is highlighted. 

5.  Click the Move Up in List button  until the plan display is moved up to the X-Y 
Plane @ Z=24. 

6. Click the Quick Draw Area button  on the side toolbar (or the Draw menu > Quick 

Draw Area command) to display the Properties of Object form. We can ignore the 
property setting shown in this form because other assignments will be made later in 
the modeling process.   

7. Click once in each of the four quadrants in the plan view to draw four area objects. 

8. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=12. 

9. Click once in each of the four quadrants in the plan view to draw four area objects. 

10. Click the Set Select Mode button  to exit Draw mode and enter Select mode. 

11. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=0. 

12. Click the drop-down box in the status bar to change the units to .  

13.  Click the Define menu > Link/Support Properties command to display the 
Link/Support Properties form. In that form: 



� Click the Add New Property button to display the Link/Support Property Data 
form. In that form: 

o Select Rubber Isolator from the Link/Support Type drop-down list. 

o Type RUB1 in the Property Name edit box. 

o Type .001 in the Mass edit box. 

o Check the U1 Direction check box in the Directional Properties area. 

o Click the Modify/Show For U1 button to display the Link/Support 
Directional Properties form. In that form: 

• Type 10000 in the Effective Stiffness edit box. 

• Click the OK button to return to the Link/Support Property Data 
form. 

o Check the U2 Direction check box. 

o Check the U2 Nonlinear check box. 

o Click the Modify/Show For U2 button to display the Link/Support 
Directional Properties form. In that form: 

• In the Properties Used for Linear Analysis Cases area, type 1.5 
in the Effective Stiffness edit box. 

• In the Properties Used for Nonlinear Analysis Cases area, type 
10 in the Stiffness edit box. 

• Type 5 in the Yield Strength edit box. 

• Type .2 in the Post Yield Stiffness Ratio edit box. 

• Accept the other values on the form. 

• Click the OK button to return to the Link/Support Property Data 
form. 

o Check the U3 Direction check box. 

o Check the U3 Nonlinear check box. 

o Click the Modify/Show For U3 button to display the Link/Support 
Directional Properties form. In that form: 

• In the Properties Used for Linear Analysis Cases area, type 1.5 
in the Effective Stiffness edit box. 

• In the Properties Used for Nonlinear Analysis Cases area, type 
10 in the Stiffness edit box. 

• Type 5 in the Yield Strength edit box. 

• Type .2 in the Post Yield Stiffness Ratio edit box. 

•  Accept the other values on the form. 

• Click the OK buttons on the Link/Support Directional 
Properties, Link/Support Property Data, and Link/Support 
Properties forms to exit all forms. 

14. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. 



15. Click the Draw menu > Draw 1 Joint Link command to display the Properties of 
Object form.  Select RUB1 from the Property drop-down box. 

16. In the plan view of the X-Y Plane @ Z=0, click on each of the nine grid intersection 
points to draw nine Links. 

17. Click the Set Select Mode button  to exit Draw mode and enter Select mode. 

18. Click the Define menu > Materials command to display the Define Materials form. 
Highlight the STEEL material and click the Modify/Show Material button to display the 
Material Property Data form. In that form: 

� Verify that the Modulus of Elasticity is 29000 and Poisson’s ratio is 0.3. 

� Click the OK buttons on the Material Property Data and Define Materials forms 
to close the forms. 

19. Click the Define menu > Area Sections command to display the Area Sections form. In 
that form: 

� Click the Add New Section button to display the Area Section Data form. In that 
form: 

o Type ROOF in the Section Name edit box. 

o  Accept the default CONC material. 

o In the Area Type area, verify that the Shell option is selected. 

o Type 6 in the Membrane edit box. 

o Type 6 in the Bending edit box. 

o In the Type area verify that the Shell option is selected. 

o Click the OK button to return to the Area Sections form. 

�  Click the Add New Section button to display the Area Section Data form. In that 
form: 

o Type FLOOR in the Section Name edit box. 

o  Accept the default CONC material. 

o In the Area Type area, verify that the Shell option is selected. 

o Type 10 in the Membrane edit box. 

o Type 10 in the Bending edit box. 

o In the Type area verify that the Shell option is selected. 

o Click the OK buttons on the Area Section Data and Area Sections forms 
to close all forms. 

20. Click the drop-down box in the status bar to change the units to . 

21. Click the Define menu > Materials command to display the Define Materials form. 
Highlight the CONC material and click the Modify/Show Material button to display the 
Material Property Data form. In that form: 

� Verify that the Mass per unit Volume is 4.662E-03 and that the Weight per unit 
Volume is 0.15. 



� Click the OK buttons on the Material Property Data and Define Materials forms 
to close the forms. 

22. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. 

23. Click the Set XZ View button . 

24. Click the Perspective Toggle button . 

25. Click the Select using Intersecting Line button  and select all of the bottom level 
columns. 

Note:   To use the Intersecting Line Selection option, click the Select using Intersecting Line 

button .  Then click the left mouse button to the left of the first level columns, and while 
holding down the left mouse button, drag the mouse to the right of the first level columns. A 
“rubberband line” will appear and all objects that this “rubberband line” passes through will be 
selected. Release the left mouse button to make the selection. 

26. Click the Select using Intersecting Line button  and select all of the top level 
columns. 

27. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Click on W14X90 in the Properties area to highlight it. 

� Click the OK button. 

28.  Click the Show Undeformed Shape button  to remove the displayed line object 
assignments. 

29. Click the Set XY View button .  The plan view of the X-Y Plane @ Z=0 appears. 

30. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ 
Z=12. 

31. Select all of the objects at this level by “windowing.” 

32. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ 
Z=24. 

33. Select all of the objects at this level by “windowing.” 

34. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Click on W24X55 in the Properties area to highlight it. 

� Click the OK button. 

35.  Click the Show Undeformed Shape button  to remove the displayed line object 
assignments. 

36. Select all of the objects at the Z=24 level by “windowing.” 



37. Click the Assign menu > Area > Sections command to display the Area Sections form. 
In that form: 

� Click on ROOF in the Sections area to highlight it. 

� Click the OK button. 

38. Click the Show Undeformed Shape button  to remove the displayed area object 
assignments. 

39. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=12. 

40. Select all of the objects at this level by “windowing.” 

41. Click the Assign menu > Area > Sections command to display the Area Sections form. 
In that form: 

� Click on FLOOR in the Sections area to highlight it. 

� Click the OK button. 

42. Click the Show Undeformed Shape button  to remove the displayed area object 
assignments. 

43. Click the Define menu > Load Cases command to display the Define Loads form. In 
that form: 

� Type LIVE in the Load Name edit box. 

� Select LIVE from the Type drop-down box. 

� Click the Add New Load button. 

� Click the OK button. 

44. Click the drop-down box in the status bar to change the units to . 

45. Select all of the objects at the Z=12 level by “windowing.” 

46. Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area 
Uniform Loads form. In that form: 

� Verify that DEAD is selected from the Load Case Name drop-down box. 

� Type 125 in the Load edit box. 

� Verify that Gravity is selected in the Direction drop-down list. 

� Click the OK button. 

47. Select all of the objects at the Z=12 level by “windowing.” 

48. Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area 
Uniform Loads form. In that form: 

� Select LIVE from the Load Case Name drop-down list. 

� Type 100 in the Load edit box. 

� Click the OK button. 



49. Click the Show Undeformed Shape button  to remove the displayed load 
assignments. 

50. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ 
Z=24. 

51. Select all of the objects at the Z=24 level by “windowing.” 

52. Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area 
Uniform Loads form. In that form: 

� Select DEAD from the Load Case Name drop-down list. 

� Type 75 in the Load edit box. 

� Click the OK button. 

53. Select all of the objects at the Z=24 level by “windowing.” 

54. Click the Assign menu > Area Loads > Uniform (Shell) command to display the Area 
Uniform Loads form. In that form: 

� Select LIVE from the Load Case Name drop-down list. 

� Type 20 in the Load edit box. 

� Click the OK button. 

55.  Click the drop-down box in the status bar to change the units to .  

56.  Click the Show Undeformed Shape button  to remove the displayed load 
assignments. 

57. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=12. 

58. Select all of the objects at the Z=12 level by “windowing.” 

59.  Click the Edit menu > Replicate command to display the Replicate form. In that form: 

� Select the Linear Tab. 

� Type -12 in the dz edit box in the Increments area. 

� Verify that the Number is 1. 

� Click the OK button. 

60. Click in the window labeled X-Y Plane @ Z=12 to make sure it is active. 

61. Click the Move Up in List button  to move the plan display up to the X-Y Plane @ 
Z=24. 

62. Select all objects at the Z=24 level by “windowing.” 

63. Click the Assign menu > Joint > Constraints command to display the Assign/Define 
Constraints form. In that form: 

� In the Choose Constraint Type to Add area, click the drop-down box that reads 
Body and then click Diaphragm.  Click the Add New Constraint button to 
display the Diaphragm Constraint form. In that form: 



o Type ROOF in the Constraint Name edit box. 

o Select the Z axis option in the Constraint Axis area if it is not already 
selected. 

o Click the OK buttons on the Diaphragm Constraint and Assign/Define 

Constraints forms to assign the diaphragm constraint. 

64.  Click the Show Undeformed Shape button  to remove the displayed constraint 
assignments. 

65. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=12. 

66. Select all objects at the Z=12 level by “windowing.” 

67. Click the Assign menu > Joint > Constraints command to display the Assign/Define 
Constraints form. In that form: 

� In the Choose Constraint Type to Add area, click the drop-down box that reads 
Body and then click Diaphragm.  Click the Add New Constraint button to 
display the Diaphragm Constraint form. In that form: 

o  Type 2ND in the Constraint Name edit box. 

o Select the Z axis option in the Constraint Axis area if it is not already 
selected. 

o Click the OK buttons on the Diaphragm Constraint and Assign/Define 
Constraints forms to assign the diaphragm constraint. 

68. Click the Show Undeformed Shape button  to remove the displayed constraint 
assignments. 

69. Click the Move Down in List button  to move the plan display down to the X-Y 
Plane @ Z=0. 

70. Select all objects at the Z=0 level by “windowing.” 

71. Click the Assign menu > Joint > Constraints command to display the Assign/Define 
Constraints form. In that form: 

� In the Choose Constraint Type to Add area, click the drop-down box that reads 
Body and then click Diaphragm.  Click the Add New Constraint button to 
display the Diaphragm Constraint form. In that form: 

o Type 1ST in the Constraint Name edit box. 

o Select the Z axis option in the Constraint Axis area if it is not already 
selected. 

o Click the OK buttons on the Diaphragm Constraint and Assign/Define 
Constraints forms to assign the diaphragm constraint. 

72. Click the Show Undeformed Shape button  to remove the displayed diaphragm 
constraint assignments. 

Note:   Before defining time history functions, locate the time history files that you wish to use.  
For this problem, we are using files named lacc_nor-1.th and Lacc_nor-2.th, but any time history 
files may be used.  A number of sample files are included with SAP2000. 



73. Click the Define menu > Functions > Time History command to display the Define 
Time History Functions form. In that form: 

� In the Choose Function Type to Add area, click the drop-down list that reads 
Sine Function and then click Function from File.   

� Click the Add New Function button to display the Time History Function 
Definition form. In that form: 

o Type LACC0 in the Function Name edit box. 

o Click the Browse button in the Function File area to display the Pick 
Function Data File form. In that form: 

• Locate and highlight the first time history file that you wish to 
use (we are using lacc_nor-1.th). 

• Click the Open button to return to the Time History Function 
Definition form. 

o Type 2 in the Header Lines to Skip edit box. 

o Type 8 in the Number of Points Per Line edit box. 

o Select the Values At Equal Intervals of option and type .02 in the edit 
box. 

o Click the OK button to return to the Define Time History Functions form. 

� Click the Add New Function button to display the Time History Function 
Definition form. In that form: 

o Type LACC90 in the Function Name edit box. 

o Click the Browse button in the Function File area to display the Pick 
Function Data File form. In that form: 

• Locate and highlight the second time history file that you wish 
to use (we are using lacc_nor-2.th). 

• Click the Open button to return to the Time History Function 
Definition form. 

o Type 2 in the Header Lines to Skip edit box. 

o Type 8 in the Number of Points Per Line edit box. 

o Select the Values At Equal Intervals of option and type .02 in the edit 
box. 

o Click the OK buttons on the Time History Function Definition and 
Define Time History Functions form to close all forms. 

74. Click the Define menu > Analysis Cases command to display the Analysis Cases form. 
In that form: 

� Click on Modal in the Case Name list to highlight it. 

� Click the Modify/Show Case button to display the Analysis Case Data - Modal 
form. In that form: 

o Type 30 in the Maximum Number of Modes edit box. 

o In the Type of Modes area select the Ritz Vectors option. 



o In the Loads Applied area, verify that Load shows in the Load Type 
drop-down list and that DEAD shows in the Load Name drop-down 
list.  Click the Add button. 

o In the Loads Applied area, select Accel from the Load Type drop-down 
list and UX from the Load Name drop-down list.  Click the Add button. 

o In the Loads Applied area, select UY from the Load Name drop-down 
list.  Click the Add button. 

o In the Loads Applied area, select Link from the Load Type drop-down 
list.  Click the Add button. 

o Click the OK button to return to the Analysis Cases form. 

� Click the Add New Case button to display the Analysis Case Data form. In that 
form: 

o Type GRAV in the Analysis Case Name edit box. 

o Select Time History from the Analysis Case Type drop-down list. 

o Select the Nonlinear option in the Analysis Type area. 

o In the Loads Applied area, verify that Load shows in the Load Type 
drop-down box and that DEAD shows in the Load Name drop-down 
box.  Select RAMPTH from the Function drop-down box. Click the Add 
button. 

o Type 100 in the Number of Output Time Steps edit box. 

o Type .1 in the Output Time Step Size edit box. 

o  Click the OK button to return to the Analysis Cases form. 

� Click the Add New Case button to display the Analysis Case Data form. In that 
form: 

o Type LAC in the Analysis Case Name edit box. 

o Select Time History from the Analysis Case Type drop-down list. 

o Select the Nonlinear option in the Analysis Type area. 

o In the Initial Conditions area, select the Continue from State at End of 
Modal History option. 

o In the Loads Applied area, select Accel from the Load Type drop-down 
box and U1 from the Load Name drop-down box.  Select LACC0 from 
the Function drop-down box, and type 0.0328 in the Scale Factor edit 
box. Click the Add button. 

o In the Loads Applied area, select U2 from the Load Name drop-down 
box and select LACC90 from the Function drop-down box. Click the 
Add button. 

o Type 3000 in the Number of Output Time Steps edit box. 

o Type .02 in the Output Time Step Size edit box. 

o In the Other Parameters area of the form, click the Modify/Show button 
for Modal Damping to display the Modal Damping form. In that form: 

• Verify that .05 shows in the Constant Damping For All Modes edit 
box. 



• In the Modal Damping Overrides area type 1 in the Mode box, 
type 0.02 in the Damping box and click the Add button. 

• In the Modal Damping Overrides area type 2 in the Mode box and 
click the Add button. 

• In the Modal Damping Overrides area type 3 in the Mode box and 
click the Add button. 

• Click the OK buttons on the Model Damping, Analysis Case Data, 
and Analysis Cases forms to close all forms. 

75. Click the Run Analysis button  to display the Set Analysis Cases to Run form. In 
that form: 

� Verify that all analysis cases are set to Run in the Action list. 

� Click the Run Now button to run the analysis. 

76.  When the analysis is complete, check the messages in the SAP Analysis Monitor 
window and then click the OK button to close the window. 

77. Click in the window labeled X-Y Plane @ Z=0 to make sure it is active. 

78. Click the Set Display Options button  (or the View menu > Set Display Options 
command) to display the Display Options for Active Window form. In that form: 

� Check the Labels box in the Joints area. 

� Click the OK button. 

79. Click on the center joint, joint 13, in the plan at Z=0 to select it. 

80. Click the Move Up in List button  twice to move the plan display up to the X-Y 
Plane @ Z=24. 

81. Click on the center joint, joint 15, in the plan at Z=24 to select it. 

82. Click the Set Display Options button  (or the View menu > Set Display Options 
command) to display the Display Options on Active Window form. In that form: 

� Uncheck the Labels box in the Joints area. 

� Click the OK button. 

83.  Click the Display menu > Show Plot Functions command to display the Plot Function 
Trace Display Definition form. In that form: 

� Select LAC from the Analysis Case drop-down box. 

� Click the Define Plot Functions button in the Choose Plot Functions area to 
display the Plot Functions form. In that form: 

o Highlight Joint 13. 

o Click the Modify/Show Plot Function button to display the Joint Plot 
Function form. In that form: 

• Verify that the Displ option is selected in the Vector Type area. 

• Select the UY option in the Component area. 



• Click the OK button to return to the Plot Functions form. 

o Highlight Joint 15. 

o Click the Modify/Show Plot Function button to display the Joint Plot 
Function form. In that form: 

• Verify that the Displ option is selected in the Vector Type area. 

•  Select the UY option in the Component area. 

• Click the OK button to return to the Plot Functions form. 

o In the Choose Function Type to Add area select Add Base Functions 
from the drop-down box and click Add Plot Function to display the 
Base Functions form. In that form: 

• Check the Base Shear Y check box. 

• Click the OK buttons on the Base Functions and Plot Functions 
forms to return to the Plot Function Trace Display Definition 
form. 

o Click on Joint 13 in the List of Functions to highlight it (select it). 

o Hold down the Ctrl key on the keyboard and click on Joint 15 to add it 
to the selection. 

o Click the Add button to move Joints 13 and 15 into the Vertical 
Functions list. 

o Click the Display button to display the displacement time histories. Note 
that there is very little difference between the 1st and roof level 
displacements. The structure is essentially moving as a rigid body on 
top of the isolators. 

o Click the OK button to close the Display Plot Function Traces form and 
return to the Plot Function Trace Display Definition form. 

� Click on Joint 15 in the Vertical Functions list to highlight it. 

� Hold down the Ctrl key on the keyboard and click on Joint 13 to add it to the 
selection. 

� Click the Remove button to move Joints 15 and 13 back into the List of 
Functions list. 

� Click on Base Shear Y in the List of Functions to highlight it. 

� Click the Add button to move Base Shear Y into the Vertical Functions list. 

� In the Horizontal Plot Function drop-down box, select Joint 13. 

� Click the Display button to display the force-displacement plot. 

� Click the OK button to close the Display Plot Function Traces form and return to 
the Plot Function Trace Display Definition form. 

� Click the Done button to close the Plot Function Trace Display Definition form. 


