Problem Q

Three Frames

Concrete

E =5000 ksi, Poissons Ratio=0.2
Beams 24" wide by 356" deap
Columns: 24" by 24"

Damper Properties
, , . E .
Effective stiffness =0 kin Stiffne ss = 1000 kfin
Effective damping =0 k- sec/fin Damping =30 k-secfin

Damping exponent= 045

Isolator Properties (lsolatorl)

“ertical (axial) stiffness = 10,000 kfin (linear)

Initial shear stiffness = 100 kfin

Shear yield force = 40 kips

Ratio of post yield shear gtiffness to initial shear stiffness =01

Time Hi
Apply the lacc_nor-1 record. Eight acceleration values are given on each
line of the file. The acceleration value is in units of crmfsec® There are
3,000 time steps at an equal spacing of 0.02 sec for a total of B0 sec.

To Do

Createthree frames, one bare, one with dampers, and one with isolators.
Create avideo (" avifile) of the nanlinear time history run. Heview the mode
shapes.

Include a 50 kip point load and a 0.25 kip-sec?/in point
/maas at each 2nd, 3rd and roof level joint of each frame
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CSI Solution Demonstrates Use of These Features
= Concrete Moment Frame
= Create Time History Video
= Dynamic Analysis
= Mode Shapes

= New Model From Template



= Link Elements

= Nonlinear Time History Analysis

Problem Q Solution

1. Click the File menu > New Model command to display the New Model form.

2. Click the drop-down box to set the units to M

3. Click on the 2D Frame button | Fames: | to display the 2D Frames form. On that form:
= Select Portal in the 2D Frame Type drop-down list.
= Type 3 in the Number of Stories edit box.
= Type 5 in the Number of Bays edit box.
= Uncheck the Restraints check box.
= Click the oK button.

4. Click the “X” in the top right-hand corner of the 3-D View window to close it.

.
5. Click the set Display Options button ki (or the View menu > Set Display Options
command) to display the Display Options for Active Window form. In that form:

= Check the Labels box in the Joints area.
= Check the Labels box in the Frames/Cables/Tendons area.
= Click the OK button.

6. Select line (beam) objects 22, 23, 24, 28, 29 and 30. Press the Delete key on the
keyboard to delete these objects.

Note: Select the objects by clicking on each one individually, using the Intersecting Line Select
Mode, or using the Select menu > Select > Labels command.

7. Click the braw menu > Quick Draw Frame/Cable/Tendon command to display the
Properties of Object form. Verify that the Line Object Type is Straight Frame. Ignore
the other values shown because the sections will be re-assigned later in the problem.

8. Click on the grid line between joints 17 and 21 to enter a line object at the base of the
isolated frame.

9. Click the set Select Mode button &’ on the side toolbar to exit Draw mode and enter
Select mode.

10. Selectjoints 1, 5, 9 and 13.

11. Click the Assign menu > Joint > Restraints command to display the Joint Restraints
form. In that form:

= Click the Fixed Base Fast Restraint button J to set all degrees of freedom
(U1, U2, U3, R1, R2 and R3) as restrained.



12.
13.
14.

15.

16.

17.

18.

19.

20.
21.

= Click the OK button.

Click the drop-down box in the status bar to change the units to {FiP. in. F j' .
Click the Define menu > Materials command to display the Define Materials form.

Click on CONC in the Materials area to highlight it (select it), and then click the
Modify/Show Material button. The Material Property Data form is displayed. In that
form:

= Type 0 in the Mass per Unit Volume edit box.

= Accept the default Weight per Unit Volume.

= Type 5000 in the Modulus of Elasticity edit box.

= Type .2 in the Poisson’s Ratio edit box, if it is not already entered.

= Click the OK buttons on the Material Property Data and Define Materials forms
to exit all forms.

Click the Define menu > Frame Sections command to display the Frame Properties
form.

In the Choose Property Type to Add area, click the drop-down box that reads Add
I/Wide Flange and then click on the Add Rectangular item.

Click the Add New Property button to display the Rectangular Section form. In that
form:

= Type BEAM in the Section Name edit box.

= Select CONC in the Material drop-down box.

= Type 36 in the Depth (t3) edit box.

= Type 24 in the Width (t2) edit box.

= Click the OK button to return to the Frame Properties form.

In the Choose Property Type to Add area, click the drop-down box that reads Add
Rectangular item.

Click the Add New Property button to display the Rectangular Section form. In that
form:

= Type COL in the Section Name edit box.

= Select CONC in the Material drop-down box.
= Type 24 in the Depth (t3) edit box.

= Type 24 in the Width (t2) edit box.

= Click the OK buttons on the Rectangular Section and Frame Properties forms to
exit all forms.

Select all beam objects (10 total).

Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display
the Frame Properties form. In that form:

= Click on BEAM in the Properties area to highlight it.
= Click the oK button.



22. Select all column objects by “windowing“ on each column line separately (18 total).

23. Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display
the Frame Properties form. In that form:

= Click on COL in the Properties area to highlight it.
= Click the ok button.

24. Click the Sshow Undeformed Shape button ' to remove the frame section
assignments and redisplay the frame object labels.

25. Click the Define menu > Link/Support Properties command to display the
Link/Support Properties form. In that form:

= Click the Add New Property button to display the Link/Support Property Data
form. In that form:

o0 Select Rubber Isolator from the Link/Support Type drop-down list.
0 Type ISO in the Property Name edit box.

o0 Type .001 in the Mass edit box.

0 Check the U1 Direction check box.

o Click the Modify/Show For U1 button to display the Link/Support
Directional Properties form. In that form:

« Type 10000 in the Effective Stiffness edit box.

* Click the oK button to return to the Link/Support Property Data
form.

o0 Check the U2 Direction check box.
o0 Check the U2 Nonlinear check box.

0 Click the Modify/Show For U2 button to display the Link/Support
Directional Properties form. In that form:

« In the Properties Used for Linear Analysis Cases area, type 10
in the Effective Stiffness edit box.

* In the Properties Used for Nonlinear Analysis Cases area, type
100 in the Stiffness edit box.

« Type 40 in the Yield Strength edit box.
¢ Type .l in the Post Yield Stiffness Ratio edit box.
* Accept the other values on the form.

26. Click the oK buttons on the Link/Support Directional Properties and Link/Support
Property Data forms to return to the Link/Support Properties form. In that form:

= Click the Add New Property button to display the Link/Support Property Data
form. In that form:

o0 Select Damper from the Link/Support Type drop-down list.
0 Type DAMP in the Property Name edit box.
o0 Type .001 in the Mass edit box.
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0 Check the U1 Direction check box.
o Check the U1 Nonlinear check box.

o Click the Modify/Show For U1 button to display the Link Support
Direction Properties form. In that form:

* In the Properties Used for Nonlinear Analysis Cases area, type
1000 in the Stiffness edit box.

¢ Type 30 in the Damping Coefficient edit box.
* Type .5 in the Damping Exponent edit box.

¢ Click the oK buttons on the Link/Support Directional
Properties, Link/Support Property Data, and Link/Support
Properties forms to exit all forms.

Click the braw menu > Draw 1 Joint Link command to display the Properties of
Object form. Select ISO from the Property drop-down box.

Click on joints 17 and 21 to draw two Link elements.

Click the set Select Mode button ﬁ, on the side toolbar to exit Draw mode and enter
Select mode.

Click the braw menu > Draw 2 Joint Link Element command to display the Properties
of Object form. Select DAMP from the Property drop-down box.

Click on joint 9 and then joint 14 to draw a Link element and then hit the Enter key on
the keyboard.

Click on joint 10 and then joint 15 to draw a Link element and then hit the Enter key on
the keyboard.

Click on joint 11 and then joint 16 to draw a Link element and then hit the Enter key on
the keyboard.

Click the set Select Mode button ﬁ, on the side toolbar to exit Draw mode and enter
Select mode.

Select all joints at the 2nd, 3rd and Roof levels by “windowing.”

Click the Assign menu > Joint Loads > Forces command to display the Joint Forces
form. In that form:

= Type -50 in the Force Global Z edit box.
= Click the ok button.
Select all joints at the 2nd, 3rd and Roof levels by “windowing.”

Click the Assign menu > Joint > Masses command to display the Joint Masses form. In
that form:

= Type .25 in the Direction 1 edit box.
= Type .25 in the Direction 3 edit box.
= Click the ok button.

Click the drop-down box in the status bar to change the units to M



40. Click the Show Undeformed Shape button =

assignments.

to remove the displayed joint mass

41. Click the set Display Options button (or the View menu > Set Display Options
command) to display the Display Options for Active Window form. In that form:
= Uncheck the Labels box in the Joints area.
= Uncheck the Labels box in the Frames/Cables/Tendons area.
= Click the ok button.

Note: Before defining time history functions, locate the time history files to be used. For this
problem, we are using a file named lacc_nor-1.th, but any time history file may be used. A
number of sample files are included with SAP2000.

42. Click the Define menu > Functions > Time History command to display the Define
Time History Functions form. In that form:

= Inthe Choose Function Type to Add area, click the drop-down box that reads
Sine Function and then click Function from File.

= Click the Add New Function button to display the Time History Function
Definition form. In that form:

0 Type LACCO in the Function Name edit box.

o Click the Browse button in the Function File area to display the Pick
Function Data File form. In that form:

* Locate and highlight the time history file to be used (we are
using lacc_nor-1.th).

¢ Click the open button to return to the Time History Function
Definition form.

o Type 2 in the Header Lines to Skip edit box.
0 Type 8 in the Number of Points Per Line edit box.

0 Select the Values at Equal Intervals option in the Values are area and
type .02 in the edit box.

o Click the oK buttons on the Time History Function Definition and
Define Time History Functions forms to exit all forms.

43. Click the Define menu > Analysis Cases command to display the Analysis Cases form.
In that form:

= Highlight (select) MODAL in the Case Name list.

= Click the Modify/Show Case button to display the Analysis Case Data form. In
that form:

o Type 30 in the Maximum Number of Modes edit box.
o0 Inthe Type of Modes area select the Ritz Vectors option.

o Inthe Loads Applied area, verify that Load shows in the Load Type drop-
down box and that DEAD shows in the Load Name drop-down box. Click
the Add button.
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In the Loads Applied area, select Accel from the Load Type drop-down
box and UX from the Load Name drop-down box. Click the Add button.

In the Loads Applied area, select Link from the Load Type drop-down
box. Click the Add button

Click the OK button to return to the Analysis Cases form.

= Click the Add New Case button to display the Analysis Case Data form. In that

form:

O O O O

Type GRAV in the Analysis Case Name edit box.
Select Time History from the Analysis Case Type drop-down box.
Select the Nonlinear option in the Analysis Type area.

In the Loads Applied area, verify that Load shows in the Load Type
drop-down box and that DEAD shows in the Load Name drop-down
box. Select RAMPTH from the Function drop-down box. Click the
Add button.

Type 100 in the Number of Output Time Steps edit box.
Type .1 in the Output Time Step Size edit box.

Click the Modify/Show button for Modal Damping in the Other
Parameters area to display the Modal bamping form. In that form:

* Type .02 in the Constant Damping For All Modes edit box.

* Click the oK buttons on the Modal Damping and Analysis Case
Data forms to return to the Analysis Cases form.

= Click the Add New Case button to display the Analysis Case Data form. In that

form:

O O O o

Type LAC in the Analysis Case Name edit box.
Select Time History from the Analysis Case Type drop-down box.
Select the Nonlinear option in the Analysis Type area.

In the Initial Conditions area, select the Continue from State at End of
Modal History option.

In the Loads Applied area, select Accel from the Load Type drop-down
box and U1 from the Load Name drop-down box. Select LACCO from
the Function drop-down box, and type 0.0328 in the Scale Factor edit
box. Click the Add button.

Type 1210 in the Number of Output Time Steps edit box.
Type .01 in the Output Time Step Size edit box.

Click the Modify/Show button for Modal Damping in the Other
Parameters area to display the Modal Damping form. In that form:

¢ Type .02 in the Constant Damping For All Modes edit box.

¢ Click the oK buttons on the Modal Damping, Analysis Case
Data and Analysis Cases forms to exit all forms.



44. Click the Analyze menu > Set Analysis Options command to display the Analysis
Flaswe Fraene

r-4 .5 .

Options form. In that form click the Plane Frame XZ Plane button @Fsee {0 set the
available degrees of freedom.

= Click the OK button.

. 3 .
45, Click the Run Analysis button to display the Set Analysis Cases to Run form. In
that form:

= Verify that all analysis cases are set to Run in the Action list.
= Click the Run Now button to run the analysis.

46. When the analysis is complete, check the messages in the SAP Analysis Monitor
window and then click the oK button to close the window.

. Start Animation
47. Click the start Animation button on the status bar at the bottom of

the screen to animate the first mode shape.

=

48. Click the Right Arrow button on the status bar at the bottom of the screen to view

the next mode shape.

=

49. Continue clicking the Right Arrow button to step through all of the mode shapes.

50. Click the Sshow Undeformed Shape button = to remove the displayed mode shape.

51. Click the File menu > Create Video> Create Multi-step Animation Video command to
display the Video File form. In that form, select the name and location for the video file
(*.avi) and click the save button. The Multi-step Video File Creation form is displayed.
In that form:

= Select LAC from the Case Name drop-down box.

= Type 50 in the Magnification Factor edit box.

= Verify that 640 by 480 is entered in the Frame Size (Pixels) edit boxes.
= Click the oK button. The *.avi file is created.

Note: After the *.avi file has been created, it can be played on any multimedia player that
supports *.avi files.

Note: The purpose of this example is to display the capabilities of SAP2000. The structural
properties of each frame have not been optimized in this example. Therefore, great care should
be taken in drawing any conclusions about the relative performance of different structural
systems based on this example.



