
 
 

CSI Solution Demonstrates Use of These Features 
� Diaphragm Constraint 

� Dynamic Analysis 

� Grid Lines 

� Mesh Areas 

�  Mode Shapes 



� New Model From Template 

�  Linear Replication 

�  Response Spectrum Analysis 

Problem Z Solution 
1.  Click the File menu > New Model command to display the New Model form. 

2. Click the drop-down box in the status bar to change the units to .. 

3. Click on the 3D Frames button  to display the 3D Frames form. In that form: 

� Select Open Frame Building from the 3D Frame Type drop-down list. 

� Type 4 in the Number of Stories edit box. 

� Type 4 in the Number of Bays, X edit box. 

� Type 4 in the Number of Bays, Y edit box. 

� Accept the default Story Height, 12. 

� Type 30 in the Bay width, X edit box. 

� Type 30 in the Bay width, Y edit box. 

� Verify that the Restraints check box is checked. 

� Click the OK button. 

4. Click the Define menu > Coordinate Systems/Grids command to display the 
Coordinate/Grid Systems form. In that form: 

� Click the Modify/Show System button to display the Define Grid form. In that 
form: 

o Verify that the Ordinates option is selected in the Display Grids as area 
in the middle right of the form. 

o Check the Glue to Grid Lines check box. 

o In the X Grid Data portion of the spreadsheet, click the -30 in the row 2 
Ordinate cell and type -35 in that cell. Click on the 30 in the row 4 
Ordinate cell and type 40 in that cell. 

o In the Y Grid Data portion of the spreadsheet, click on the -30 in the 
row 2 Ordinate cell and type -40 in that cell. 

o Click the OK buttons on the Define Grid and Coordinate/Grid Systems 
forms to exit all forms. 

5.  Verify that the 3-D View window is active. The window is active when its title is 
highlighted. 

6. Click the Set Display Options button  to display the Display Options for Active 
Window form. In that form: 



� Check the Fill Objects check box. 

� Click the OK button. 

7. Click in the window labeled X-Y Plane @ Z=48 to activate it. 

8. Click the Set Display Options button  to display the Display Options for Active 
Window form. In that form: 

�  Check the Fill Objects check box. 

� Click the OK button. 

9.  Click the XZ View button . The view switches to the X-Z plane @ Y=60 and 
appears as shown in Figure Z-1. 

  

Figure Z-1:  Screen After Step 9 

10. Click the Quick Draw Area button   on the side toolbar to display the Properties of 
Object form. 

11. Click once in each of the regions labeled “A,” “B,” “C” and “D” in Figure Z-1 to enter 
four area objects. 

12. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Z Plane option. 

� Type -60 in the Y= edit box. 

� Click the OK button.  The screen appears similar to that shown in Figure Z-1 
(except that the location is now at Y=-60). 

13. Click once in each of the regions labeled “E,” “F,” “G” and “H” in Figure Z-1 to enter 
four area objects. 



14.  Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the Y-Z Plane option. 

� Type 60 in the X= edit box. 

� Click the OK button.  The screen appears as shown in Figure Z-

 

Figure Z-2:  Screen After Step 14 

15. Click once in each of the regions labeled “A,” “B,” “C” and “D” in Figure Z-2 to enter 
four area objects. 

16.  Click the View menu > Set 2D View command to display the Set 2D View form. 

17.  In that form: 

� Select the Y-Z Plane option. 

� Type -60 in the X= edit box. 

� Click the OK button.  The screen appears similar to that shown in Figure Z-2 
(except that the location is now at X=-60). 

18. Click once in each of the regions labeled “E,” “F,” “G” and “H” in Figure Z-2 to enter 
four area objects. This completes the drawing of the shear walls. 

19. Click the Set Select Mode button  to exit draw mode and enter select mode. 

20. Click the Define menu > Materials command to display the Define Materials form.  In 
that form: 

� Highlight the CONC material and click the Modify/Show Material button to 
display the Material Property Data form. In that form: 

� Verify that the Mass per unit Volume is 4.662E-03. 

� Verify that the Weight per unit Volume is 0.15. 



� Click the OK button on the Material Property Data form to return to the 
Define Materials form. 

� Highlight the STEEL material and click the Modify/Show Material button to 
display the Material Property Data form. In that form: 

� Verify that the Mass per unit Volume is 0.0152. 

� Verify that the Weight per unit Volume is 0.49. 

� Click the OK buttons on the Material Property Data and Define 
Materials forms to exit all forms. 

21. Click the drop-down box in the status bar to change the units to . 

22. Click the Define menu > Materials command to display the Define Materials form.  In 
that form: 

� Highlight the CONC material and click the Modify/Show Material button to 
display the Material Property Data form. In that form: 

� Verify that the Modulus of Elasticity is 3600. 

� Verify that Poisson’s ratio is 0.2. 

� Click the OK button to return to the Define Materials form. 

� Highlight the STEEL material and click the Modify/Show Material button to 
display the Material Property Data form. In that form: 

� Verify that the Modulus of Elasticity is 29000. 

� Verify that Poisson’s ratio is 0.3. 

� Click the OK buttons on the Material Property Data and Define 
Materials forms to exit all forms. 

23. Click the Define menu > Frame Sections command to display the Frame Properties 
form. In that form: 

� In the Choose Property Type to Add area, click the drop-down box that reads 
Import I/Wide Flange and then click on the Import Pipe item. 

� Click the Add New Property button to display the Section Property File form.  In 
that form: 

o Locate the Sections.pro file, which should be located in the same 
directory as the SAP2000 program files.  Highlight Sections.pro and 
click the Open button. 

o A form appears with a list of all pipe sections in the database.  In that 
form: 

� Scroll down and click on the P3 (3" diameter standard pipe 
section) item. 

� Click the OK buttons on the database and Pipe Section forms to 
return to the Frame Properties form. 

� In the Choose Property Type to Add area, click the drop-down box that reads 
Add I/Wide Flange and then click on the Add Rectangular item.   

� Click the Add New Property button to display the Rectangular Section form. In 
that form: 



o Type BMCOL in the Section Name edit box. 

o Select CONC from the Material drop-down box. 

o Type 20 in the Depth (t3) edit box. 

o Type 20 in the Width (t2) edit box. 

o Click the OK buttons on the Rectangular Section and Frame Properties 
forms to exit all forms. 

24. Click the Define menu > Area Sections command to display the Area Sections form. In 
that form: 

� Click the Modify/Show Section button to display the Area Section Data form. In 
that form: 

o Type WALL in the Section Name edit box. 

o  Accept the default CONC material 

o In the Area Type area, verify that the Shell option is selected. 

o In the Thickness area, verify that both the Membrane and the Bending 
thicknesses are 12. 

o In the Type area, verify that the Shell option is selected. 

o Click the OK button to return to the Area Sections form. 

� Click the Add New Section button to display the Area Section Data form. In that 
form: 

o Type FLOOR in the Section Name edit box. 

o  Accept the default CONC material. 

o Type 10 in the Membrane edit box. 

o Type 10 in the Bending edit box. 

o Click the OK buttons on the Area Section Data and Area Sections forms 
to exit all forms. 

25. Click the drop-down box in the status bar to change the units to . 

26. Click in the window labeled Y-Z Plane @ X=-60 to verify it is active. 

27. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Y Plane option. 

� Type 48 in the Z= edit box. 

� Click the OK button. 

28. Click the Set Display Options button  (or the View menu > Set Display Options 
command) to display the Display Options for Active Window form. In that form: 

� Check the Labels box in the Joints area. 

� Click the OK button. 



29.  Click the Draw Rectangular Area button  on the side toolbar or the Draw menu > 

Draw Rectangular Area command to display the Properties of Object form. In that 
form: 

� Verify that FLOOR is shown in the Property drop-down box. 

31. Click on joint 25 and then joint 105 to enter a single area object for the entire floor. 

32.  Click the Set Select Mode button  to exit Draw mode and enter Select mode. 

33. Select all objects in the X-Y Plane @ Z=48 by “windowing.” 

34. Click the Edit menu > Mesh Areas command to display the Mesh Selected Shells form. 
In that form: 

� Select the Mesh using selected Joints on edges option. 

Note:  The Mesh at intersections with grids option would work equally well. 

� Click the OK button. 

34.  Select all objects in the X-Y Plane @ Z=48 by “windowing.” 

35. Click the Edit menu > Replicate command to display the Replicate form. In that form: 

� Verify the Linear Tab is selected. 

� In the Distance area type -12 in the dz edit box. 

� Verify that 0 is entered in the dx and dy edit boxes. 

� Type 3 in the Number edit box. 

� Click the OK button to proceed with the replication and create the other floor 
diaphragms. 

36.  Click the Select All button  on the side toolbar. 

37. Click the Assign menu > Joint > Constraints command to display the Assign/Define 
Constraints form. In that form: 

� In the Choose Constraint Type for Add area click the drop-down box and select 
Diaphragm. 

� Click the Add New Constraint button to display the Diaphragm Constraint form. 
In that form: 

o Type DIAPH in the Constraint Name edit box. 

o Select the Z Axis option in the Constraint Axis area. 

o  Check the Assign a different diaphragm constraint to each different 
selected Z level box.  This will assign a diaphragm constraint at each 
floor level with the different diaphragms identified by their respective 
elevations. 

o Click the OK buttons on the Diaphragm Constraint and Assign/Define 
Constraints forms to exit all forms. 

38. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Y Plane option. 



� Verify that 0 is entered in the Z= edit box. 

� Click the OK button. 

39. Select all objects at this level by “windowing.” 

40. Click the Assign menu > Joint > Restraints command to display the Joint Restraints 
form. In that form: 

� Click the Fixed Support button in the Fast Restraints area. 

� Click the OK button. 

41. Click the Select All button  on the side toolbar to select all objects. 

42.  Click the Assign menu > Frame/Cable/Tendon > Frame Sections command to display 
the Frame Properties form. In that form: 

� Click on BMCOL in the Properties area to highlight it. 

� Click the OK button. 

43. Click the Show Undeformed Shape button  to remove the displayed frame section 
assignments. 

44. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Z Plane option. 

� Type -60 in the Y= edit box. 

� Click the OK button. 

45. Click the Define menu > Coordinate Systems/Grids command to display the 
Coordinate/Grid Systems form. In that form: 

� Click the Modify/Show System button to display the Define Grid form. In that 
form: 

o Verify that the Ordinates option is selected in the Display Grids as area 
in the middle right of the form. 

o In the Z Grid Data portion of the spreadsheet, type z6 in the Grid ID cell 
of row 6. In that same row, type 78 in the Ordinate cell and click in the 
Line Type cell to display Primary, the Visibility cell to display Show, 
and Bubble Loc. cell to display Right. 

o Click the OK buttons on the Define Grid and Coordinate/Grid Systems 
forms to exit all forms.   

46. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Z Plane option. 

� Type -60 in the Y= edit box. 

� Click the OK button.  The screen appears as shown in Figure Z-3. 



 

Figure Z-3:  Screen After Step 46 

47. Click the Quick Draw Frame/CableTendon button   on the side toolbar or the 
Draw menu > Quick Draw Frame/Cable/Tendon command to display the Properties 
of Object form. In that form: 

� Select P3 from the Property drop-down box. 

� Verify that Continuous is shown in the Moment Releases drop-down box. 

48. Click on the grid line at the point labeled “A” in Figure Z-3 to enter the flagpole frame 
object. 

49. Click the Set Select Mode button  to exit Draw mode and enter Select mode. 

50. Click the drop-down box in the status bar to change the units to . 

51. Click on the joint at the top of the flagpole to select it. 

52. Click the Assign menu > Joint > Masses command to display the Joint Masses form. In 
that form: 

� Type .00065 in the Direction 1, Direction 2 and Direction 3 edit boxes. 

� Click the OK button. 

53. Click the Show Undeformed Shape button  to remove the displayed joint mass 
assignments. 

54. Click the drop-down box in the status bar to change the units to . 



55. Click the Define menu > Functions > Response Spectrum command to display the 
Define Response Spectrum Functions form. In that form: 

� In the Choose Function Type to Add area, click the drop-down box and select 
UBC 94 Spectrum. 

� Click the Add New Function button to display the Response Spectrum UBC 94 

Function Definition form. In that form: 

� Type SPEC1 in the Function Name edit box. 

� In the Parameters area, select 2 from the Soil Type drop-down list. 

� Click the OK buttons on the Response Spectrum UBC 94 Function 

Definition and Define Response Spectrum Functions forms to exit all 
forms. 

56. Click the Define menu > Analysis Cases command to display the Analysis Cases form. 
In that form: 

�  Click the Add New Case button to display the Analysis Case Data – Linear 
Static form. In that form: 

o Type RS1 in the Analysis Case Name edit box. 

o In the Analysis Case Type area, select Response Spectrum from the 
drop-down list. 

o Accept the default Modal Combination option, CQC. 

o Accept the default Directional Combination option, SRSS.   

o In the Loads Applied area:  

• Verify that U1 is shown in the Load Name drop-down list. 

• Verify that SPEC1 is shown in the Function drop-down list. 

• Type 32.2 in the Scale Factor edit box. 

• Click the Add button. 

o In the Loads Applied area: 

• Select U2 in the Load Name drop-down list. 

• Verify that SPEC1 is shown in the Function drop-down list. 

• Type 9.66 (.3*32.2=9.66) in the Scale Factor edit box. 

• Click the Add button. 

o Verify that Modal Damping is set to Constant at 0.05. 

o Click the OK button. 

o Click on MODAL in the Case Name list to highlight it. 

o Click the Modify/Show Case button to display the Analysis Case Data - Modal 
form. In that form: 

o Select the Ritz Vectors option in the Type of Modes area. 

o In the Number of Modes area, type 20 in the Maximum Number of 
Modes edit box. 



o Select Accel from the Load Type drop-down box in the Loads Applied 
area. 

o Verify that UX is shown in the Load Name drop-down list. 

o Click on the Add button. 

o Select UY from the Load Name drop-down list. 

o Click on the Add button. 

o Click the OK buttons on the Analysis Case Data – Modal and Analysis 
Cases forms to exit all forms. 

57. Click the Run Analysis button  to display the Set Analysis Cases to Run form. In 
that form: 

� Click the Run Now button. 

58. When the analysis is complete, check the messages in the SAP Analysis Monitor 
window (there should be no warnings or errors) and then click the OK button to close 
the window. 

59. Click in the window with the elevation showing to make sure it is active. 

60. Click the View menu > Set 2D View command to display the Set 2D View form. In that 
form: 

� Select the X-Z Plane option. 

� Type -60 in the Y= edit box. 

� Click the OK button. 

61. Click the Display menu > Show Deformed Shape command to display the Deformed 

Shape form. In that form: 

� Select RS1 from the Case/Combo Name drop-down box. 

� Click the OK button. 

62. Right click the joints at the top and bottom of the flagpole to see their displacements. 

Note:   If the top of the flagpole goes off of the screen when the deformed shape is displayed, 

click the Zoom Out One Step button   as many times as required to bring the joint back on to 
the screen. 


